No Signal when Outputting with HDMI

What’s the issue?

Can't get a video signal to the monitor source via the camera's HDMI connection, whether it be getting a live video feed onto an HDTV, accessing the video playback function through the HDMI connection, getting live video feed to appear on field monitor, or getting a video signal to pass through broadcast converter to TV monitor or switcher.

Where does it apply?

  • HERO7 Black
  • HERO (2018)
  • HERO6 Black
  • HERO5 Black
  • HERO5 Session
  • HERO4
  • HERO3+
  • HERO3
  • HD HERO2

How to fix it

  1. Make sure that your HDTV Input Channel is set to the same input port that you have the HDMI Cable connected to.  For example: HDMI Input Port 3, set TV to HDMI Input 3.  If the input on the TV is set incorrectly, you will not get any preview.
  2. Make sure that the camera is powered OFF and there are no BacPac accessories attached to your camera before you connect the camera to the HDMI Cable.  If this doesn't work, please try powering the camera ON first and then connect the camera to the TV using your HDMI Cable.  Once the camera is ON and connected you should initially see a live preview of whatever the camera is currently facing.  Use the front Power/Mode button on the camera to scroll until you see a Play icon on the camera's (and TV's) front LCD screen.
  3. Did you previously edit these files on the SD card at all or are they exactly as the camera has written them?  This includes altering the folders, file names, file order, etc.  If so, they will not play back through the camera.
  4. If the user has the video setting set to 24 or 48 FPS, have them get out of that frame rate and try different res/fps (1080-30 and 1080-60 are some basic settings to test, along with 720-60 and 720-120).  Since 24/48fps can put the most strain on a video signal, they might be using a monitor or broadcast device that's unable to recognize a proper handshake connection.  The same goes for the superview video settings (HERO3+ Black)
  5. If sending a video signal like 720-60 through a broadcast converter to a monitor source, they can force set the EDID on the converter to desired output (i.e. 720-60), instead of the camera determining the EDID, to get that output signal.
  6. Set video setting to WVGA, which should output 480p.  If they can confirm this resolution is being seen as a live feed, it should establish the baseline for the live feed, and then the user can change it back to desired resolution/FPS
  7. Perform the software update, or re-flash the software update if camera is already up-to-date, as this can restore the proper HDMI functions and allow certain functions to work again, like the playback mode
  8. Try connecting the camera to a different HDMI Cable if you have one available. Are you using the GoPro HDMI Cable or a generic brand?  If possible, try connecting the camera to a different TV or TV input port.  Again, please be sure that you have the TV input channel set to the corresponding input port the HDMI cable physically plugged into, as many TVs have multiple HDMI ports.
  9. If nothing else works, try backing up the files on your SD card by copying them to your computer and then format your SD card and check to see whether newly recorded files play back properly via HDMI.  Here are instructions for reformatting your SD card: HERO7 BlackHERO6 Black / HERO5 Black / HERO5 Session / HERO3 & HERO3+ / HERO4.

no video, no output, no out put, black screen, black monitor, black tv, no playback, no play back, HDMI, connection, connectivity, video feed, live stream, live feed, broadcast, converter, video signal, type of port, EDID, input, live, stream
Was this article helpful? Yes | No
Thanks for your feedback.

Feedback

Please tell us how we can make this article more useful.

Reason:
Comments:
Characters Remaining 255